Votol EM-100 & EM-150 controllers

General Discussion about electric vehicles.
larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 05 2020 1:00pm

It could be poor heat path from fets to heatsink so protection sensor is measuring too high temps even if nothing is felt on the outside. I should open my first controller and have a look :wink:
Last edited by larsb on Jan 05 2020 3:58pm, edited 1 time in total.
Ride on!

Bartosh   10 W

10 W
Posts: 96
Joined: May 10 2017 3:32pm

Re: Votol EM-100 & EM-150 controllers

Post by Bartosh » Jan 05 2020 2:49pm

SilentEnduro wrote:
Jan 05 2020 9:31am
Tried to replace my regular Votol EM-150 with Votol EM-150 SP (CAN version) to see is there any difference.
Thanks for the video. So it's time to test EM-200? (-;

User avatar
SilentEnduro   1 W

1 W
Posts: 60
Joined: Oct 10 2019 2:56am
Location: Lviv, Ukraine

Re: Votol EM-100 & EM-150 controllers

Post by SilentEnduro » Jan 05 2020 3:25pm

Bartosh wrote:
Jan 05 2020 2:49pm
SilentEnduro wrote:
Jan 05 2020 9:31am
Tried to replace my regular Votol EM-150 with Votol EM-150 SP (CAN version) to see is there any difference.
Thanks for the video. So it's time to test EM-200? (-;
Definitely :)

kibe019   1 µW

1 µW
Posts: 1
Joined: Dec 31 2019 6:05am

Re: Votol EM-100 & EM-150 controllers

Post by kibe019 » Jan 08 2020 8:39am

Hi everyone new user here, i buy em100 controller but my supplier cannot configure it properly. Can anyone help me how to set up the controller in proper settings? I want to set it torque for an uphill road since our way has to much uphill. BTW my motor is QS2000w, thanks in advance.

SilverLine   100 W

100 W
Posts: 141
Joined: Oct 09 2017 2:53pm
Location: Denmark

Re: Votol EM-100 & EM-150 controllers

Post by SilverLine » Jan 08 2020 11:31am

kibe019 wrote:
Jan 08 2020 8:39am
Hi everyone new user here, i buy em100 controller but my supplier cannot configure it properly. Can anyone help me how to set up the controller in proper settings? I want to set it torque for an uphill road since our way has to much uphill. BTW my motor is QS2000w, thanks in advance.
You could start with giving us, screenshot of page 1,2, and 3 :-)

shankar   1 µW

1 µW
Posts: 1
Joined: Jan 13 2020 5:16am

Re: Votol EM-100 & EM-150 controllers

Post by shankar » Jan 13 2020 6:27am

Hello Guys,
I'm new to this forum. Could anybody please tell me How to start QS3000 motor which is connected to EM-150 controller.

I'm sorry to ask this stupid question from you excellent peoples. I referred the manual and connected the motor and controller but it is not starting.

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 13 2020 10:33am

Ride on!

MVS   100 µW

100 µW
Posts: 7
Joined: Jan 11 2014 4:37am

Re: Votol EM-100 & EM-150 controllers

Post by MVS » Jan 14 2020 10:43am

I just received a Mid-Drive QS Motor 120 2000W with a Votol EM-100 72V motor controller.
I can't get the throttle voltages to stick on the software configuration but the system is running fine with a Citroen throttle.
On my application I would like to have the motor maximum speed independant from the battery voltage (vs SOC) for race purposes with mixed ICE vehicles, On the software configuration all speed limitations seem to be dependant from the maximum currently available battery voltage and this is useless to me. I would like to limit the maximum motor speed to some rpm value compatible with the end of race battery voltage level. Is this possible?

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 14 2020 1:43pm

Throttle setting doesn’t work in all controllers. I guess yours is an older one.

Speed can be set independently of voltage.
Ride on!

MVS   100 µW

100 µW
Posts: 7
Joined: Jan 11 2014 4:37am

Re: Votol EM-100 & EM-150 controllers

Post by MVS » Jan 15 2020 6:13am

I checked it again:

Mid 95%; No Flux Weak; Prohibit the speed limit checked:
70,1V OCV -> 2260 rpm no load
79,1V OCV -> 2580 rpm no load

Mid 100%; No Flux Weak; Speed limit enabled 50%:
78,6V OCV -> 1344 rpm
72,6V OCV -> 1240 rpm

I can't find the parameter that limits the rpm independant the battery voltage.

MVS   100 µW

100 µW
Posts: 7
Joined: Jan 11 2014 4:37am

Re: Votol EM-100 & EM-150 controllers

Post by MVS » Jan 15 2020 10:06am

Pic Scr1 Votol.jpg
Pic Scr1 Votol.jpg (77.94 KiB) Viewed 1518 times
HW 0.07 on a EM100. Does anyone have another one like this?

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 15 2020 2:48pm

You check if you want to use dual voltage setting or not in the program. Read manual for where it is
Ride on!

User avatar
SilentEnduro   1 W

1 W
Posts: 60
Joined: Oct 10 2019 2:56am
Location: Lviv, Ukraine

Re: Votol EM-100 & EM-150 controllers

Post by SilentEnduro » Jan 17 2020 3:37am

just pics of disassembled EM150
photo_2020-01-17_10-19-41.jpg
photo_2020-01-17_10-19-41.jpg (191.84 KiB) Viewed 1225 times
photo_2020-01-17_10-19-31.jpg
photo_2020-01-17_10-19-31.jpg (183.24 KiB) Viewed 1225 times
some experiments soon)))

SilverLine   100 W

100 W
Posts: 141
Joined: Oct 09 2017 2:53pm
Location: Denmark

Re: Votol EM-100 & EM-150 controllers

Post by SilverLine » Jan 17 2020 5:46am

SilentEnduro wrote:
Jan 17 2020 3:37am
just pics of disassembled EM150

photo_2020-01-17_10-19-41.jpg
photo_2020-01-17_10-19-31.jpg

some experiments soon)))
How many volts, are the big caps ?

Bartosh   10 W

10 W
Posts: 96
Joined: May 10 2017 3:32pm

Re: Votol EM-100 & EM-150 controllers

Post by Bartosh » Jan 17 2020 5:57am

SilentEnduro wrote:
Jan 17 2020 3:37am
some experiments soon)))
Better check out the mosfets if you're planning on doing the shunt mod (-; hopefully these are not "domestics" (eg. TDMs).

BTW we can compare it with an old P (non-CAN) version I own (the burnt one). I'm wondering if they didn't change the fets in SP as the official ratings had been decreased (470A to 380A?).

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 17 2020 12:43pm

A mosfet comparison would be interesting :D

Shunt mods are not necessary since controller is unlocked..

I wonder if you can find the temp sensor (if there is one)
How are the fets mounted to the heatsink?
Is there a good heat path?
Ride on!

Bartosh   10 W

10 W
Posts: 96
Joined: May 10 2017 3:32pm

Re: Votol EM-100 & EM-150 controllers

Post by Bartosh » Jan 17 2020 1:03pm

This is what's inside of EM-150P: https://www.alldatasheet.com/datasheet- ... 0N027.html

I will post some pictures later, need to resize it. Anyway there's no obvious sign of a failure inside my controller... keep looking though. :|

Lars, what do you mean by unlocked? Batt current? Max phase amps limit still in place and unknown, IIRC? I wonder how they measure it (no lems).

SilverLine, 100V caps (SLF, CD288H).

Edit: photos (thermal "brackets" removed) https://s.amsu.ng/2ja0xjyhIU8N

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 17 2020 1:51pm

Battery current setting is not limited in program. I think battery current is calculated from the measured phase current or opposite if there's only one shunt
Ride on!

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 17 2020 2:05pm

So it's 24 mosfets with rds of 2.8mohm, three phases of 8 total, 4 parallel high, 4 low side.

It's either 120A per mosfet, 480A or max 8x208w dissipation (speced at 100 deg C) setting the limits with perfect current sharing. 1600+ watts is a lot to get rid of.

I wonder if there's a derating factor that could be assumed for parallel mosfets. I bet it could be found somewhere on these 300 pages :wink: https://www.google.com/url?sa=t&source= ... t3TcvezSUE
Ride on!

User avatar
Laerson   1 mW

1 mW
Posts: 15
Joined: Mar 16 2018 7:30am
Location: The Netherlands

Re: Votol EM-100 & EM-150 controllers

Post by Laerson » Jan 18 2020 4:37am

Hi all,

Lovely thread you've got going here, it's been really helpful so far!
Unfortunately I can't say the same for the VOTOL manual :roll:
I recently started testing an EM100 to replace the VESC on my electric minibike.

This is my experience so far, I hope it might be useful to others:

Setup
Controller VOTOL EM100
Motor QS 2000W Hub motor
Battery Lithium-ion 54V / 75A
Throttle Domino potentiometer with resistors (signal 1-5V)
Control 3-speed switch

Hall angle
There seems to be a difference in the direction you run. I started with -120 degrees and my motor ran forward, but poorly, specially at low RPM. Next, I changed the value to (positive) 120 degrees and of course the motor ran backwards. But really smooth and quiet, no humming.

I suspect there is a correction angle in the software itself which only works in the positive direction, but of course I can't say for sure.

Exchange hall & exchange phase
To run my motor forwards I tried every combination of the ''exchange hall'' and ''exchange phase'' options. For some reason my motor only hums with these settings. No rotation, besides maybe an initial jerk.

Finally I set the controller to 120 and physically switched the phase wires blue and green, and hall wires green and yellow. Now my motor runs really smooth in the forward direction.

3-speed & flux weakening
Right now I've connected my 3-speed switch and it shows up in display as gears L-M-H. But until now I haven't found the settings that work for me. I'm really confused by the flux weakening, specially by how it interacts with the 3-speed settings. I'd much rather had a three boxes for L-M-H acceleration and speed.

I will do some more testing soon, to be continued..

Bartosh   10 W

10 W
Posts: 96
Joined: May 10 2017 3:32pm

Re: Votol EM-100 & EM-150 controllers

Post by Bartosh » Jan 18 2020 5:02am

larsb wrote:
Jan 17 2020 2:05pm
It's either 120A per mosfet, 480A or max 8x208w dissipation (speced at 100 deg C) setting the limits with perfect current sharing. 1600+ watts is a lot to get rid of.
Have you ever measured real (stall) phase current of your old S/P version? I'm about to install the votol again in couple days. We can compare s/p : sp. If it's still 470a, we're on a very thin line. Assuming the specs were true. I think upgrading mosfets is an option.

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 18 2020 6:42am

Mosfet specs look good as far as i can tell but i am no expert in this.

The spec shows pulsed drain current as 480A so i think the basic limitation is the cooling if design is properly balanced - for peak output 470A is not close to the limits of the mosfet specs since there are four of them..
Ride on!

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 18 2020 9:55am

Laerson wrote:
Jan 18 2020 4:37am

Hall angle
I suspect there is a correction angle in the software itself which only works in the positive direction, but of course I can't say for sure.

The correction is the phase angle setting. If it runs weird in one direction and good in the other means that either the setting is still not optimised towards the hall sensor location or that the rotation speed creates the need for advanced angle setting since a minimal delay in one direction will turn out as a double delay in the other direction.

Exchange hall & exchange phase
To run my motor forwards I tried every combination of the ''exchange hall'' and ''exchange phase'' options.

When the angle setting is not correct then no combination will work. I think you should ask QS what the normal phase angle shift is for this motor controller combination. It’s 60 for the 3000W..

3-speed & flux weakening
Right now I've connected my 3-speed switch and it shows up in display as gears L-M-H. But until now I haven't found the settings that work for me. I'm really confused by the flux weakening, specially by how it interacts with the 3-speed settings. I'd much rather had a three boxes for L-M-H acceleration and speed.
What’s your issue in the settings? Phase current sets torque, rpm percent sets rpm and flux weakening sets.. :D
Ride on!

twikis   10 mW

10 mW
Posts: 26
Joined: Nov 24 2015 7:25pm

Re: Votol EM-100 & EM-150 controllers

Post by twikis » Jan 18 2020 1:03pm

So I'm trying to decide between a Kelly KLS and Votol EM-150SP, but I'm uncertain about a few things:

1. Since I'm running a 11s battery; can the Votol be set to a LVC of ~30V and still run reliably at that voltage?

2. For legal reasons I'd like to have the option to limit the speed to exactly 50 km/h or so, indepedent of the battery voltage (so that I can still go 50 km/h on a low battery, when the limiter is on). With a Kelly KLS that's possible, as you can set a fixed erpm limit and the controller will go up to that speed with full power, and then simply won't go higher. How does the speed limit function work in the Votol? Is there some magic behind it limiting the frequency, or does the speed limiting percentage setting only influence PWM?

larsb   1 MW

1 MW
Posts: 1554
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by larsb » Jan 18 2020 1:25pm

Don’t buy a kelly KLS.. i’ve had five of these go kaput. Poor design, poor quality and low power.

Low volt of the votol: don’t know but fairly sure it’s in the thread already. Why 11s? That’s not any standard battery voltage so i guess you don’t have this battery already.

The rpm limit of the votol limits rpm
Ride on!

Post Reply