Help

General Discussion about electric vehicles.
Post Reply
Joelo211   1 µW

1 µW
Posts: 4
Joined: May 28 2020 9:38am

Help

Post by Joelo211 » May 28 2020 9:43am

ae_1590676547846.jpg
Sabvoton display
ae_1590676547846.jpg (425.36 KiB) Viewed 215 times
Hello new here :bigthumb:
I have this problem I dont know what else to do can anyone help me please, I am a new to the ebike stuff sorry hope to learn here :D

User avatar
amberwolf   100 GW

100 GW
Posts: 30417
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Help

Post by amberwolf » May 28 2020 3:43pm

Do any of these posts about Sabvoton 30H error help?
search.php?keywords=sabvoton+30h&terms= ... mit=Search

Joelo211   1 µW

1 µW
Posts: 4
Joined: May 28 2020 9:38am

Re: Help

Post by Joelo211 » May 28 2020 10:54pm

Have read everything but nothing that I allready done :?
Still gives the error
Thank you for your response

Sab. 72150 M

obcd   100 W

100 W
Posts: 158
Joined: Jul 16 2019 3:45pm

Re: Help

Post by obcd » May 29 2020 12:06pm

As it says communication error, you would expect that the display isn't communicating with the motor controller anymore.
I don't know the system details. Some use a seperate rx tx wire on ttl level. Some use linbus over one wire. Some use can.
It can be an electrical problem between the motor controller and the dislay, but it's also possible that the motor controller is completely dead. It might show the same error in such case.

j bjork   10 kW

10 kW
Posts: 553
Joined: Aug 31 2018 3:01pm
Location: Linköping, Sweden

Re: Help

Post by j bjork » May 29 2020 12:21pm

It is not easy for anyone to help without any information.
No info of what parts has been used.
If it has worked before.
If it has, what happened when it stopped working.
What has been tested or tried to make it work.
What happens when it is turned on, and what doesn't happen.
No info in the header what it is about, just "help"

A thread like this is unlikely to get good help, and I might even say it doesn't deserve it either.

Joelo211   1 µW

1 µW
Posts: 4
Joined: May 28 2020 9:38am

Re: Help

Post by Joelo211 » May 30 2020 4:01pm

The controller is a sab 72150 M
Te bike runs nice and the controller has no errors on the software everything looks normal except for that in the display.

From the firts time i plug it it says that but the motor runs and the controller is working fine, maybe a damage display?

Joelo211   1 µW

1 µW
Posts: 4
Joined: May 28 2020 9:38am

Re: Help

Post by Joelo211 » May 30 2020 4:04pm

obcd wrote:
May 29 2020 12:06pm
As it says communication error, you would expect that the display isn't communicating with the motor controller anymore.
I don't know the system details. Some use a seperate rx tx wire on ttl level. Some use linbus over one wire. Some use can.
It can be an electrical problem between the motor controller and the dislay, but it's also possible that the motor controller is completely dead. It might show the same error in such case.
the controller works motor is running nice and normal only thing is the error on display may is just damage.. thank you for your respose friend

Post Reply