Ebike

General Discussion about electric bicycles.
Post Reply
Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Ebike

Post by Jp88 » Dec 22 2019 2:16am

Hi i got a ebike and put a bigger and better wheel on buy it going backwards and ideas would be great it a dayun ebike

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Dec 22 2019 2:31am

Any help would be appreciated

User avatar
dogman dan   100 GW

100 GW
Posts: 35234
Joined: May 17 2008 12:53pm
Location: Las Cruces New Mexico USA

Re: Ebike

Post by dogman dan » Dec 22 2019 6:38am

The wires on the new motor are not colored the same as the old one. Try swapping around the big fat wires to find a combination that makes it run good forward. There will be one good forward, and one good reverse combination, the other 7 will run shitty, or not run at all.

There are threads that explain this in more detail.

User avatar
TommyCat   1 kW

1 kW
Posts: 327
Joined: Jan 22 2018 8:05pm
Location: North-west Illinois, USA

Re: Ebike

Post by TommyCat » Dec 22 2019 10:06am

If this is a BLDC motor with hall sensors, perhaps this would be easier to use. If it runs well, but just in reverse. Just the changes in the lower right blue box would be necessary.

Image


Regards,
T.C.
See my completed Magic Pie V5 rear hub E-Bike build Here!

User avatar
MadRhino   100 GW

100 GW
Posts: 6045
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: Ebike

Post by MadRhino » Dec 22 2019 11:43am

Well, if it is running fine backwards, half the job of finding the proper combo is done. Swap any two (only two) of the big phase wires, then swap one of the 3 other possible combinations of the (blue, green, yellow) hall wires. One of them will give you a perfect forward motion.
Make it fool-proof, and I will make a better fool.
Current bikes
Street: https://s20.postimg.org/ewrvugywt/Session_04_2015.jpg
Dirt: https://s20.postimg.org/lbqwr55ml/IMG_0157.jpg

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Dec 22 2019 12:26pm

It going backwards when you twist the throttle

User avatar
E-HP   100 kW

100 kW
Posts: 1072
Joined: Nov 01 2018 9:20pm

Re: Ebike

Post by E-HP » Dec 22 2019 1:56pm

Jp88 wrote:
Dec 22 2019 12:26pm
It going backwards when you twist the throttle
Ahh, with that clarification, I think the best advice would be to read the 3 posts above.

User avatar
spinningmagnets   100 GW

100 GW
Posts: 11363
Joined: Dec 21 2007 10:27pm
Location: Ft Riley, NE Kansas

Re: Ebike

Post by spinningmagnets » Dec 22 2019 3:37pm

There is a possibility that this scooter has a reverse switch, and it is not wired properly. Meaning, the reverse switch is now always "on"...

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Dec 22 2019 4:38pm

So what would be the best thing to do

User avatar
spinningmagnets   100 GW

100 GW
Posts: 11363
Joined: Dec 21 2007 10:27pm
Location: Ft Riley, NE Kansas

Re: Ebike

Post by spinningmagnets » Dec 22 2019 4:48pm

Find the model number of the controller, and post it here.

docw009   100 kW

100 kW
Posts: 1172
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: Ebike

Post by docw009 » Dec 22 2019 5:15pm

It;s right there in the flow chart.
You have three heavier wires - Yellow, Blue, Green
You have three thinner wires - Yellow, Blue, Green plus two more, Red and Black?

1) Swap the thick Yellow and Green wires.
2) Swap the thin Yellow and Blue wires.

If the chart is correct, Zoom ZOom.

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Dec 22 2019 5:23pm

That is my controller box

User avatar
E-HP   100 kW

100 kW
Posts: 1072
Joined: Nov 01 2018 9:20pm

Re: Ebike

Post by E-HP » Dec 22 2019 6:50pm

Jp88 wrote:
Dec 22 2019 4:38pm
So what would be the best thing to do
Since it's not going to fix itself, print out this thread and bring it and the bike to a shop that can swap the wires for you, per the advice provided.

User avatar
amberwolf   100 GW

100 GW
Posts: 28398
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Ebike

Post by amberwolf » Dec 23 2019 12:51am

Jp88 wrote:
Dec 22 2019 4:38pm
So what would be the best thing to do
Follow the advice already given.

Or try giving the complete information others already asked for, that you haven't bothered to do yet.

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Jan 14 2020 3:37pm

Hi could any one help me my bike had a new back wheel everything working fine then yesterday had a adicent and still everything working fine then last night but the batteries one charge and just gone down today and but the batteries back in and it all comes out but still saying the batteries flat when it isn't and not moving at all any help would be great full

markz   100 GW

100 GW
Posts: 7824
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: Ebike

Post by markz » Jan 14 2020 4:35pm

get a digital multi meter and measure the voltage

User avatar
E-HP   100 kW

100 kW
Posts: 1072
Joined: Nov 01 2018 9:20pm

Re: Ebike

Post by E-HP » Jan 14 2020 4:43pm

Jp88 wrote:
Jan 14 2020 3:37pm
Hi could any one help me my bike had a new back wheel everything working fine then yesterday had a adicent and still everything working fine then last night but the batteries one charge and just gone down today and but the batteries back in and it all comes out but still saying the batteries flat when it isn't and not moving at all any help would be great full
Ah so does this mean that you solved the earlier problem? Thanks for following up. What finally worked?

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Jan 14 2020 5:49pm

Yh we got the back wheel working been all gd up till today when I charge my batter when downstairs put the batteries in and not it saying battery flat when it not and it not working

User avatar
E-HP   100 kW

100 kW
Posts: 1072
Joined: Nov 01 2018 9:20pm

Re: Ebike

Post by E-HP » Jan 14 2020 6:37pm

Jp88 wrote:
Jan 14 2020 5:49pm
Yh we got the back wheel working been all gd up till today when I charge my batter when downstairs put the batteries in and not it saying battery flat when it not and it not working
Yup, the beauty of the forum is that a person can ask a question and receive lots of support and great advice. And the same user can then contribute to the forum by coming back afterwards and letting people know exactly what they ended up doing to fix the problem, so the next guy that reads the thread benefits. So what worked?

mark5   100 kW

100 kW
Posts: 1306
Joined: Dec 28 2011 9:26pm
Location: USA

Re: Ebike

Post by mark5 » Jan 14 2020 6:50pm

A long time ago before web browsers existed people used to get help from others through mailing lists. It was expected that they'd post a recap after they got their problem solved. Otherwise they were less likely to get helped the next time.

Jp88, what was the problem before and how did you fix it?

Jp88   10 mW

10 mW
Posts: 23
Joined: Dec 22 2019 2:09am

Re: Ebike

Post by Jp88 » Jan 14 2020 7:19pm

The problem was the back wheel was not working before it Coz it was not clouer code.

Post Reply