Bafang Max Drive - configuring

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
altie   1 µW

1 µW
Posts: 1
Joined: Nov 03 2019 5:25pm

Re: Bafang Max Drive - configuring

Post by altie » Nov 03 2019 5:45pm

e-bikeNZ wrote:
Mar 12 2018 12:56am
Hi idave, Main Changes as follows:

In Basic settings on my bike the Limit Speed was already 100% on every Assist level, so I just spread the assist levels for a gradual increase of assist on most settings, with a jump at the top end for Hills.
In the Pedal Assist setting, Current Decay at 8 and Keep Current at 80%, so it didn't fade if I slowed going up hills.
Left Work Mode at 10, as performance seemed to drop off slightly up hills whenever I raised it.
In the Torque Settings, reduced the Start & Full KG so it was less effort pedaling up hills & likewise raised max current to 100% on all settings except Speed0. Lowered the delta voltages also across the board, as this appeared to again make it easier pedalling up the Hills.

As you can probably guess, I don't really use power assistance on the flat except when I am in a hurry and then on Full Assistance can easily do 30-50 kph. My focus has been really on making it easy to get back up a very long steep hill on the way back to my house and it's certainly achieved that.
Great work ebikeNZ. This is a popular mid drive and your post is the most comprehensive I have found on instructions for configuring.

I currently have a converted bike with a Bafang BBS01, but am looking for a friend at a similar fitout to yours (XDS ecruz) but with a 11.5Ah battery.

My friend wants to use it for a flat 8km commute, as well as some hills riding in the Adelaide Hills. Nothing like your 430m rise though.....

A few questions:

a) how has it gone after a year of use?
b) any problems with motor wear running at the increased speeds?
c) If I just changed the max speed settings at the console and nothing in the advanced config, would you expect any problems?

Great work again. How can you help me with these questions?

User avatar
e-bikeNZ   10 µW

10 µW
Posts: 6
Joined: Feb 09 2018 8:10pm

Re: Bafang Max Drive - configuring

Post by e-bikeNZ » Nov 04 2019 12:28am

Had no problems and wouldn't expect you will either, especially if you are just changing the display console settings.
Bottecchia Krypton 29er
Bafang MAX drive 250W 36V,
490wh Panasonic Battery

Joe_in_alaska   1 µW

1 µW
Posts: 1
Joined: Nov 23 2019 4:20am

Re: Bafang Max Drive - configuring

Post by Joe_in_alaska » Nov 23 2019 6:16am

dceish wrote:
Nov 19 2018 10:14am
Hi All,

Any clue on how to configure DP C07 display/MM G330.250 motor without usb? C07 does not have usb port nor my menu does not have psd view -> cannot edit LUd or SPl option digits from default.

Thanks in advance!
Did you ever figure out a way to enter the 0512 password?

pisu   1 µW

1 µW
Posts: 1
Joined: Dec 30 2019 10:53am

how to configure ultra max as bbsh

Post by pisu » Jan 24 2020 2:56pm

how to configure Ultra Max as bbsX so that it responds exactly as a BBSH does.
Bafang Ultra Max 1500wts engine
DPC display 18
Batery 48v 15amp

This is my contribution
I have 3 BBS02 75O, I have mounted them on several bicycles and I am very happy but I wanted more power, so I acquired the Ultra and it was a great disappointment, the typical jerks that everyone complains about.
For Ultra to work exactly like a BBsX:
The changes are marked with red
What is not marked is unchanged
In the Torque tab, the first column is configured so that when starting from the state of rest you have to exert force so as not to force the battery.
Note 1, this setting is in sport mode.
Note 2, the eco mode does not change.
Note 3, sorry for my English, I'm Argentine, from Rosario.
Thank you
Greetings
Attachments
Basic as BBsx.png
Basic as BBsx.png (47.46 KiB) Viewed 849 times
PAS as BBsx.png
PAS as BBsx.png (42.66 KiB) Viewed 849 times
Torque as BBsx.png
Torque as BBsx.png (47.96 KiB) Viewed 849 times

Tjeska   10 W

10 W
Posts: 78
Joined: Sep 26 2016 2:48am
Location: Europe

Re: Bafang Max Drive - configuring

Post by Tjeska » Jan 29 2020 4:07pm

After the first 30km's of driving with the AM1000, I have tried some settings from the Frey AM1000 topic & started to tweak those.
Now I really think i'm close to the perfect MTB/Trail settings for the ultra max.

You need to work a little (if you set the display to 9 power levels, its great) to get the power out of the drive, but thats how i like it the most.
Will post the other tab's later.

Image

cvin   1 W

1 W
Posts: 63
Joined: Jul 03 2016 8:33pm
Location: Tucson, AZ

Re: Bafang Max Drive - configuring

Post by cvin » Jan 30 2020 2:01am

Tjeska which display do you have? I do not have the option of 9 levels on my dcp-18, just 5 in eco and 5 in sport

These changes you made did they smooth out the pas well so no jerking

The more info you guys can post here about changes will be great, i am about dive into trying to get my programming lined out better and mainly just want to smooth out the jerking

Thanks

Tjeska   10 W

10 W
Posts: 78
Joined: Sep 26 2016 2:48am
Location: Europe

Re: Bafang Max Drive - configuring

Post by Tjeska » Jan 31 2020 5:11am

cvin wrote:
Jan 30 2020 2:01am
Tjeska which display do you have? I do not have the option of 9 levels on my dcp-18, just 5 in eco and 5 in sport
500c, bought it on Ebay of Ali i think
These changes you made did they smooth out the pas well so no jerking
They make the power much more linear, but the higher the PAS setting the more risk at jerking because of the added power the drive has of course.
Other tabs:
Image

Image

I find these settings the perfect MTB/Trail settings, mostly drive on PAs setting 3 or 4 when on trails.
Higher settings are for road use/commuting.

cvin   1 W

1 W
Posts: 63
Joined: Jul 03 2016 8:33pm
Location: Tucson, AZ

Re: Bafang Max Drive - configuring

Post by cvin » Feb 01 2020 3:17am

hoping to do some programming with the egg rider this weekend, or at least get the activation/updates and connection set up..

purchased the dcp18 from eunorau with the 9 levels pas, should be here next week

will post back on how my settings end up, what worked for me etc

anxious to compare my stock settings to these
thanks for the feedback on how yours are doing

teirobc   1 µW

1 µW
Posts: 2
Joined: Feb 02 2020 1:22pm

Re: Bafang Max Drive - configuring

Post by teirobc » Feb 02 2020 1:27pm

Hi, Egg rider is a very smart tool but unfortunately, as far as I know, does not have the "Torque" page settings that seems to be very useful for max drive

teirobc   1 µW

1 µW
Posts: 2
Joined: Feb 02 2020 1:22pm

Re: Bafang Max Drive - configuring

Post by teirobc » Feb 02 2020 1:49pm

Hi all, this is my e-bike 27.5" (entry level) that most of you most probably not known equipped with M400 (P/N MM G330.250) also called Max Drive and a battery with 504W.
Image

I'm just following with attention all the settings and notes that you guys have done and also the same from other forum but torque information are really rare and not completely clear to me apart for the Delta Voltage table.
The only one that have posted some information and notes was "e-bikeNZ" that is disappeared from the forum since November last year and other data coming from "tjeska" and "pisu" are too specific for Ultra Max.
Could anyone support me with explanation about Torque parameters functions in the table or even better shows his setting and explain why?
Thanks in advance

cvin   1 W

1 W
Posts: 63
Joined: Jul 03 2016 8:33pm
Location: Tucson, AZ

Re: Bafang Max Drive - configuring

Post by cvin » Feb 02 2020 4:57pm

I did not realize the egg rider does not have the torque settings page, hoping you are wrong

if I have time to get it connected etc tonite I will confirm either way

if you are right I will sell it and just use the computer

Tom   100 W

100 W
Posts: 219
Joined: Aug 02 2007 5:31pm

Re: Bafang Max Drive - configuring

Post by Tom » Feb 02 2020 5:31pm

In the comments here robocam aka "Just Enjoying Life" (replying to a comment about the torque tab) indicates the EggRider can program those settings now too. Not sure if he was replying to the generic ability to program or to program torque. It's clearly missing in eggrider's youtube video from a year ago:

https://www.youtube.com/watch?v=dE2Vmq5bMo4

Karl mentions needing to run a specific exe (presumably newer version of the programming software) to get the torque programming tab:

https://electricbike-blog.com/2017/11/2 ... ike-drive/
In order to access the program with the torque setting, you need to run the executable Controllerst_torque.exe inside the zip file.

Tom   100 W

100 W
Posts: 219
Joined: Aug 02 2007 5:31pm

Re: Bafang Max Drive - configuring

Post by Tom » Feb 02 2020 6:16pm

teirobc wrote:
Feb 02 2020 1:49pm
Could anyone support me with explanation about Torque parameters functions in the table
See robocam's video. He explains some of the parameters. Spd0 would be the settings for stand still, Spd20 would be 20% of maximum speed, and so on. Start KG would be minimum force required to initiate torque sensing (Min Cur%) and Full KG would be the force at which Max Cur% is blended in. If you make both Min and Max Cur 100% as pisu did above I think you would have no blended torque sensing but more of an on/off.

Karl also explains the parameters here: https://electricbike-blog.com/2017/11/2 ... ike-drive/

cvin   1 W

1 W
Posts: 63
Joined: Jul 03 2016 8:33pm
Location: Tucson, AZ

Re: Bafang Max Drive - configuring

Post by cvin » Feb 02 2020 10:03pm

I can confirm the torque setting page is on the egg rider


not going to change any of my settings until the 9 level pas gets here

will update this after I do

hoping to clear most of a day to mess with settings, ride, change etc

Tom   100 W

100 W
Posts: 219
Joined: Aug 02 2007 5:31pm

Re: Bafang Max Drive - configuring

Post by Tom » Feb 03 2020 1:13am

I would test changing the spd0 and see if it applies to both sport/eco. My guess is it will apply to both, with eco being some % transformation of sport. If not then I would guess sport is whatever torque settings you program on the controller, and eco is a separate torque setting that can't be programmed.

Bikegirl   1 W

1 W
Posts: 51
Joined: Apr 02 2019 5:30am

Re: Bafang Max Drive - configuring

Post by Bikegirl » Feb 22 2020 2:55am

HI Guys

I have ones of these drives second hand and it has the wrench symbol up. not sure where to start fault finding. controller or motor?

Can anyone point me in the right direction? it seems the speed sensor is not working also.

Bikegirl   1 W

1 W
Posts: 51
Joined: Apr 02 2019 5:30am

Re: Bafang Max Drive - configuring

Post by Bikegirl » Feb 22 2020 3:19am

I found the manual here and I have error "30" so some comms failure somewhere...

*off to investigate*

http://www.cr-service.se/E-FLY/Bafang/M ... Manual.pdf

Bikegirl   1 W

1 W
Posts: 51
Joined: Apr 02 2019 5:30am

Re: Bafang Max Drive - configuring

Post by Bikegirl » Feb 23 2020 4:51am

So far I suspect the display as no blown mosfets on the controller and getting throttle 0-5v feedback from torque sense cable (red 5v, black 0v, grey signal 0-5v) BUT getting good power return on the right pins and no shorts (used Luna BBSHD wiring diagram) from the display so cabling from display to controller is good.

I have an eggrider on order that *should* be plug n play. Hopefully that will let me know if i have a good controller or not.

I'm keen to add to the fault finding info and if anyone has any additional info on fault finding this drive please add links here.

I would really like to know what the pinout is for the torque sense cables are (the two plugs under the controller when its unscrewed from its mount (one 2pin = green and purple, ?? , one 4 pin = red 5v, white ??, grey signal 0-5v, black 0v.)

sorry for taking over the thread, please move if this is inappropriate.

User avatar
fechter   100 GW

100 GW
Posts: 14542
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Bafang Max Drive - configuring

Post by fechter » Feb 23 2020 6:05pm

Bikegirl wrote:
Feb 22 2020 2:55am
HI Guys

I have ones of these drives second hand and it has the wrench symbol up. not sure where to start fault finding. controller or motor?

Can anyone point me in the right direction? it seems the speed sensor is not working also.
The wrench symbol might just be the service reminder. If the speed sensor is not working it will cause problems. You could try resetting the service reminder.
"One test is worth a thousand opinions"

Post Reply